qgis su ubuntu 17.10

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

qgis su ubuntu 17.10

Alessandra Santi
ciao,
ho installato una ubuntu 17.10 sono sempre in fase di sistemazione di
alcune cosette.
Ho agganciato i repo di qgis e installata l'ultima versione 2.18.14.
Dopo l'avvio mi appare un messaggio di errore [*]
Da quanto ho letto in rete รจ un problema legato alla versione di matplotlib.
Trovo una soluzione qui https://forum.ubuntu-it.org/viewtopic.php?p=4905717
Dovrei fare una modifica alla riga 49 del file
/home/alessandra/.qgis2/python/plugins/statist/statistdialog.py ?
e come?

Ecco la versione installata di matplotlib:
dpkg -l | grep matplotlib
ii  python-matplotlib                          2.0.0+dfsg1-2ubuntu3
                    amd64        Python based plotting system in a
style similar to Matlab
ii  python-matplotlib-data                     2.0.0+dfsg1-2ubuntu3
                    all          Python based plotting system (data
package)

grazie
ciao
Ale.a




----------------------------------
[*]
Impossibile caricare il plugin statist a causa di un errore chiamando
il metodo classFactory()

ImportError: cannot import name NavigationToolbar2QTAgg
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 333, in
startPlugin
    plugins[packageName] = package.classFactory(iface)
  File "/home/alessandra/.qgis2/python/plugins/statist/__init__.py",
line 77, in classFactory
    from statist import StatistPlugin
  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 607, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/alessandra/.qgis2/python/plugins/statist/statist.py", line 35, in
    import statistdialog
  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 607, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/alessandra/.qgis2/python/plugins/statist/statistdialog.py",
line 49, in
    from matplotlib.backends.backend_qt4agg import
NavigationToolbar2QTAgg as NavigationToolbar
ImportError: cannot import name NavigationToolbar2QTAgg


Versione Python: 2.7.14 (default, Sep 23 2017, 22:06:14) [GCC 7.2.0]
Versione di QGIS: 2.18.14 Las Palmas, ff83b9a

Path di Python:
/usr/share/qgis/python
/home/alessandra/.qgis2/python
/home/alessandra/.qgis2/python/plugins
/usr/share/qgis/python/plugins
/usr/lib/python2.7
/usr/lib/python2.7/plat-x86_64-linux-gnu
/usr/lib/python2.7/lib-tk
/usr/lib/python2.7/lib-old
/usr/lib/python2.7/lib-dynload
/usr/local/lib/python2.7/dist-packages
/usr/lib/python2.7/dist-packages
/usr/lib/python2.7/dist-packages/PILcompat
/usr/lib/python2.7/dist-packages/gtk-2.0
/home/alessandra/.qgis2//python
_______________________________________________
Gulp mailing list
[hidden email]
https://lists.gulp.linux.it/listinfo/gulp